Back to overview
Degraded
Merchant PayTabs Dashboard login disruption
Aug 28, 2021 at 10:21am UTC
Affected services
Merchant Dashboard
Resolved
Aug 28, 2021 at 12:42pm UTC
The incident has been resolved
Affected services
Created
Aug 28, 2021 at 10:21am UTC
Dear Merchant,
We have experienced a service disruption from 2021-08-28 01:21 PM . Our engineering team worked on identifying the root cause and implementing a solution. Some merchants were not be able to log in to their PayTabs merchant dashboard, however the transactions continue processing successfully without disruptions. All services are restored by 2021-08-28 01:47 PM.
PayTabs Team
Affected services