Important Notice - Payment Gateway Disruption, Tuesday 18 November 2025
Resolved
Nov 18, 2025 at 2:54pm UTC
The incident has been resolved
Affected services
Created
Nov 18, 2025 at 11:48am UTC
Dear Merchant,
We wish to advise that due to a global Cloudfare outage, certain credit/debit card transactions and integrations may be failing. You may also experience limited access to your PayTabs merchant dashboard and PayTabs.com during this time.
While we regret any business interruption this may cause, please rest assured that we are treating this with the highest priority and are actively working with our partners to resolve the matter as quickly as possible.
We aim to keep you informed and provide updates accordingly. We appreciate your patience and understanding.
PayTabs Team
عزيزي التاجر،
نود إبلاغكم بأنه نتيجة لانقطاع عالمي في خدمة Cloudflare، قد تواجه بعض المعاملات باستخدام البطاقات الائتمانية ووسائل الدفع الأخرى، بالإضافة إلى عمليات الربط والتكامل، حالات فشل مؤقت. كما قد تواجهون وصولًا محدودًا إلى لوحة تحكم التاجر في PayTabs وموقع PayTabs.com خلال هذه الفترة.
بينما نأسف لأي انقطاع قد يؤثر على أعمالكم، نؤكد لكم أن فريقنا يتعامل مع هذه المسألة بأولوية قصوى، ويعمل بنشاط مع شركائنا لحلها في أسرع وقت ممكن.
سنوافيكم بالتحديثات بشكل مستمر. نُقدّر صبركم وتفهمكم.
فريق بيتابس
Affected services