Manual Withdrawal Cut-Off Time Change
Resolved
Oct 11, 2022 at 9:57am UTC
UAE: Monday - Friday, before 11:00 AM UAE Time
KSA: Sunday - Thursday, before 11:00 AM KSA Time
Affected services
Created
Oct 11, 2022 at 9:52am UTC
Dear Merchant,
Greetings of the day.
We would like to draw your attention that the cut-off time for the manual withdrawal has been changed from 12:00 PM to 11:00 AM, Monday - Friday for UAE merchants , and from 12:00 PM to 11:00 AM, Sunday - Thursday for Saudi merchants, effective of: 11 October 2022.
Kindly make sure that you request your manual withdrawal before 11:00 AM to make sure that you are settled at the same day of your request.
If you have any further queries on this regard, please don't hesitate in contacting us: customercare@paytabs.com
Stay Safe
PayTabs Team
Affected services