Back to overview
Degraded

Important Notice - Payment Gateway Disruption (KSA Only), Friday 23 May 2025

May 23, 2025 at 10:23am UTC
Affected services
Payment Gateway

Resolved
May 25, 2025 at 5:21am UTC

The incident has been resolved

Created
May 23, 2025 at 10:23am UTC

Dear valued merchant,

We wish to advise that certain credit/debit card transactions were failing due to an unexpected issue from our card payment scheme providers, on Friday 23 May 2025, 13:32 till 13:28 KSA Time. We have confirmed that the services are back to normal from 14:30 KSA Time.

For any further assistance, please reach out to our team: customercare@paytabs.com

PayTabs Team

عزيزي التاجر ،

نحيطكم علماً بأن خدمات استقبال المدفوعات من بعض البطاقات الإئتمانية ووسائل الدفع الأخرى كانت غير متاحة يوم الجمعة 23 مايو 2025 ، من الساعة الواحدة و النصف حتى الثانية والنصف مساء بالتوقيت المحلي السعودي، و تم تأكيد عودة الخدمة من الساعة الثانية و النصف مساء في حينها.

في حال كانت هنالك اي استفسارات بهذا الصدد ، يرجى التواصل مع فريقنا: customercare@paytabs.com

فريق بيتابس