Back to overview
Degraded

Important Notice - Payment Gateway SMS Services  ( UAE/ Oman / Jordan/ Paymes)

Feb 11, 2025 at 6:00am UTC
Affected services
Plugins

Resolved
Feb 12, 2025 at 5:02am UTC

This has been resolved

Created
Feb 11, 2025 at 6:00am UTC

Dear Valued Merchant,

We wish to advise that PayTabs SMS transmission services are currently experiencing a minor service interruption.

While we sincerely regret any inconvenience, please rest assured we are working to restore the SMS service as soon as possible.

We will keep you informed and updated accordingly.

For further assistance, please get in touch with our team: customercare@paytabs.com

Thank you for your patience and understanding.

PayTabs Team