Back to overview
Downtime

Important Notice - Service Disruption Egypt ONLY ,04 March 2024, 21:30 - 23:48 Egypt time (GMT+2)

Mar 4, 2024 at 6:30pm UTC
Affected services
Payment Gateway
Merchant Dashboard
Plugins
SDKs
APIs

Resolved
Mar 12, 2024 at 9:09am UTC

The incident has been resolved

Created
Mar 4, 2024 at 6:30pm UTC

Dear Valued Merchant,
  
We wish to advise that earlier today: Monday 4 March 2024, 21:30 to 23:48 Egypt Time (+03:00 GMT) certain credit/debit card transactions were failing due to an unexpected issue encountered by our payment card scheme provider.

While we regret the inconvenience caused, we are pleased to report that normal services have now resumed.

We appreciate your patience and understanding and look forward to being of continued service.

PayTabs Team