Back to overview
Downtime

Important Notice - Service Disruption KSA ONLY ,27 February 2024, 05:00 - 05:30 PM (GMT+3)

Feb 27, 2024 at 2:00pm UTC
Affected services
Payment Gateway
Merchant Dashboard
Plugins
SDKs
APIs

Resolved
Feb 27, 2024 at 2:30pm UTC

incident Resolved

Created
Feb 27, 2024 at 2:00pm UTC

Dear Valued Merchant,

We wish to advise that we had technical difficulties that led to certain credit/debit card transactions failing with limited access to the merchant dashboard, our team did its best to get everything to regular as soon as possible.

All our services are working properly now.
  
We appreciate your patience and understanding.

PayTabs Team

عزيزي التاجر،

نود اشعاركم بأننا واجهنا صعوبات فنية أدت إلى فشل بعض عمليات
بطاقة الائتمان/الدفع مع وصول محدود إلى لوحة تحكم التاجر، وقد بذل فريقنا قصارى جهده لإعادة كل شيء إلى طبيعته في أسرع وقت ممكن.
جميع خدماتنا تعمل ومتاحه لكم الآن.

نحن نقدر صبركم وتفهمكم.

فريق بيتابس