Important Notice - Service Disruption KSA ONLY ,6 December 2023, 05:00 PM - 12:20 PM AST (GMT+3)
Resolved
Dec 6, 2023 at 10:14am UTC
The incident has been resolved
Affected services
Created
Dec 6, 2023 at 2:00am UTC
Dear Valued Merchant,
We wish to advise that we had technical difficulties that led to certain credit/debit card transactions failing with limited access to the merchant dashboard, our team did its best to get everything to regular as soon as possible.
All our services are working properly now.
We appreciate your patience and understanding.
PayTabs Team
عزيزي التاجر،
نود اشعاركم بأننا واجهنا صعوبات فنية أدت إلى فشل بعض عمليات
بطاقة الائتمان/الدفع مع وصول محدود إلى لوحة تحكم التاجر، وقد بذل فريقنا قصارى جهده لإعادة كل شيء إلى طبيعته في أسرع وقت ممكن.
جميع خدماتنا تعمل ومتاحه لكم الآن.
نحن نقدر صبركم وتفهمكم.
فريق بيتابس
Affected services