Back to overview
Downtime

Important Notice - Service Disruption KSA ONLY ,1 October 2023, 03:30 PM - 05:30 PM AST (GMT+3)

Oct 1, 2023 at 12:30pm UTC
Affected services
Payment Gateway
Merchant Dashboard
Plugins
SDKs
APIs

Resolved
Oct 2, 2023 at 9:52am UTC

The incident has been resolved

Created
Oct 1, 2023 at 12:30pm UTC

Dear Valued Merchant,

We wish to advise that certain credit/debit card transactions are failing, with limited access to your merchant dashboard.
While we regret any business interruption, please rest assured we are following up on this issue with the respective card payment scheme providers to resolve the matter.

We will keep you informed and updated accordingly.
We appreciate your patience and understanding.

PayTabs Team