Back to overview
Managinig invoices (PayLinks) manualy have been upgraded
Feb 1, 2023 at 5:00am UTC
Affected services
Merchant Dashboard
Resolved
Feb 1, 2023 at 2:11pm UTC
The incident has been resolved
Affected services
Created
Feb 1, 2023 at 5:00am UTC
Dear Merchant,
Greetings of the day,
Kindly note that the way of managing invoices (Paylinks) has been updated, you can now manage your invoice details easily and efficiently by using the edit button, you MUST CLICK ON EDIT BUTTON to create a new invoice and add any invoice items you would like.Please note that inline editing the invoice items are now disabled.
If you have any further queries in this regard, please don't hesitate in contacting us: customercare@paytabs.com
Best Regards
PayTabs Team
Affected services