Back to overview
Degraded

Important Notice - Service Disruption ,30 November 2022, 02:24 CT (08:24 UTC)

Nov 30, 2022 at 8:00am UTC
Affected services
Payment Gateway

Resolved
Nov 30, 2022 at 12:30pm UTC

Dear Merchants,

Service is fully restored at (12:38 UTC - 30 November 2022 ) .

We appreciate your patience and understanding.

Be well,

PayTabs Team

Created
Nov 30, 2022 at 8:00am UTC

Dear Valued Merchant,

We wish to advise that certain credit/debit card transactions are failing due to an unexpected issue from our card payment scheme providers in UAE, KSA and Egypt.

While we regret any business interruption, please rest assured we are following up with the respective card payment scheme providers.

We will keep you updated accordingly.

We appreciate your patience and understanding.

For further assistance, please don't hesitate in contacting us: customercare@paytabs.com

Be well,

PayTabs Team