Back to overview
Degraded
Emergency Maintenance Notification on 26th October 2022 / KSA
Oct 26, 2022 at 3:00am UTC
Affected services
Payment Gateway
Resolved
Oct 27, 2022 at 11:36am UTC
The incident has been resolved
Affected services
Created
Oct 26, 2022 at 3:00am UTC
Dear merchant,
Due to an emergency maintenance, PayTabs merchants in KSA market may experience a minor service disruption from 6:00 AM to 6:30 AM AST time, on Wednesday 26th October 2022.
We thank you for your patience and rest assured an update will be required once the maintenance is complete.
If you require any assistance, please don't hesitate in contacting us: customercare@paytabs.com
Stay Safe
PayTabs Team.
Affected services