Back to overview

"Transactions History" Display Limitation

Oct 12, 2022 at 3:00am UTC
Affected services
Merchant Dashboard

Resolved
Oct 21, 2022 at 11:43am UTC

The incident has been resolved

Created
Oct 12, 2022 at 3:00am UTC

Dear Merchant,

Greetings from PayTabs,

Please be aware that new enhancements have been performed on the "Transactions" menu that only allows you to see the last 21 days' transactions. If you want to check an older transaction feel free to navigate to the search menu that will display all the results within the provided date range. To know more, please check the below solution article:
https://support.paytabs.com/en/support/solutions/articles/60000714924-get-to-know-the-transactions-menu-item-and-how-to-manage-it

If you have any further concerns, please don't hesitate to contact us.