Back to overview
Important Notice: Downtime for PayTabs Dashboard: KSA
Sep 22, 2022 at 10:09am UTC
Affected services
Payment Gateway
Merchant Dashboard
Support Channels
Resolved
Oct 6, 2022 at 1:05pm UTC
The incident has been resolved
Affected services
Created
Sep 22, 2022 at 10:09am UTC
Dear valued merchant,
We observed PayTabs Payment Gateway - KSA was intermittently experiencing availability on all services including but not limited to merchant dashboard and secure API between 10 AM AST and 10.50 AM AST. We have confirmed that the services are back to normal from 10.50 AM AST.
Affected services