Back to overview
Degraded

customer care email down time

May 18, 2022 at 4:00pm UTC
Affected services
Support Channels

Resolved
May 19, 2022 at 10:11am UTC

The incident has been resolved

Created
May 18, 2022 at 4:00pm UTC

Dear Valued Merchant,

We wish to notify that our customer care email: customercare@paytabs.com is failing to receive your queries due to an unforeseen circumstance.
While we regret any delay in responding to your queries, please rest assured we are following up to have this resolved as soon as possible.

We will keep you informed and updated accordingly.
For urgent concerns, please contact us via WhatsApp on +971522189208
We thank you for your patience and understanding.

Stay Safe,

PayTabs Team