STC PAY DOWNTIME (Resolved)
Resolved
Feb 24, 2022 at 7:30pm UTC
We are pleased to report that normal service has now been resumed
Affected services
Updated
Feb 24, 2022 at 9:52am UTC
We are working on it , thank you for your patience.
Affected services
Created
Feb 13, 2022 at 9:00am UTC
Dear Valued Merchant,
We wish to advise that from 13 February 2022 till date, certain STC PAY transactions are failing. This is due to an unexpected issue from STC PAY which is being experienced across the kingdom.
While we regret any business interruption, please rest assured we are following up on this issue with STC Pay. We will be updating you as soon as the service is back again.
For further queries. please contact our team: customercare@paytabs.com
Thank you for your patience and support and we appreciate your understanding.
Stay Safe,
PayTabs Team
Affected services