Back to overview
Degraded
Issue with our upstream provider (MasterCard MPGS)
Nov 24, 2021 at 9:00am UTC
Affected services
Payment Gateway
Merchant Dashboard
Plugins
SDKs
APIs
Resolved
Nov 24, 2021 at 10:58am UTC
resolved
Affected services
Created
Nov 24, 2021 at 9:00am UTC
Our upstream provider, MasterCard MPGS, was experiencing an issue which affected all E-Commerce transactions processed in Saudi Arabia through the MPGS gateway. This issue has been resolved.
Affected services