Can't Log In
Resolved
Aug 8, 2021 at 11:49am UTC
The PayTabs 2.0 Dashboard Access incident is resolved. For the merchants impacted, we’re sorry for this minor disruption caused by not being able to access the dashboard.
Affected services
Updated
Aug 8, 2021 at 10:59am UTC
The Paytabs Merchant Dashboard access is stable. Users can access their merchant dashboard, as normal. We continue monitoring the situation. Next update will be within 1-2 hours.
Affected services
Created
Aug 8, 2021 at 10:48am UTC
Some users may be experiencing trouble when logging in to PayTabs's 2.0 Dashboard. Our team is currently investigating issues.
Next update will be provided in 2-3 hours.
Affected services