Back to overview
Degraded

Merchant PayTabs Dashboard login disruption

Jun 11, 2021 at 2:04pm UTC
Affected services
Merchant Dashboard

Resolved
Jun 13, 2021 at 5:23am UTC

The incident has been resolved

Updated
Jun 11, 2021 at 2:05pm UTC

Dear Merchant,

PayTabs dashboard login is back to normal for all merchants, if you experience any further disruption in accessing your merchant dashboard, please contact our customer care team: customercare@paytabs.com

PayTabs Team

Created
Jun 11, 2021 at 2:04pm UTC

Dear Merchant,

We’re currently experiencing a service disruption. Our engineering team is working to identify the root cause and implement a solution. Some merchants might not be able to log in to their PayTabs merchant dashboard, however the transactions continue processing successfully without disruptions. We will be updating you soon.

PayTabs Team